OpenVZ Web Panel: Panel requires Ruby 1.8


OpenVZ Web Panel: Panel requires Ruby 1.8


После установки OpenVZ WebPanel 2.4 на Debian 7 возникла ошибка:
Fatal error: Panel requires Ruby 1.8 (Ruby 1.9 is not supported).


Исправление нашлось на странице OWP на GitHub.

Перед запуском установки OWP нам необходимо установить ruby 1.8 и "переключалку":
apt-get install ruby-switch ruby1.8

Далее переключаем версию ruby:
ruby-switch --set ruby1.8


После этих манипуляций можно смело запускать инсталлятор OWP.

Создание шаблонов для OpenVZ на Debian.


Создание шаблонов для OpenVZ на Debian.


Сегодня мы будем собирать собственный шаблон Debian для OpenVZ виртуализации.

Установка и запуск ВМ на базе OpenVZ


Установка и запуск ВМ на базе OpenVZ


Продолжение цикла статей про OpenVZ. Сегодня мы будем учиться устанавливать openvz виртуальную машину.

Запуск OpenVZ виртуализации под Debian


Запуск OpenVZ виртуализации под Debian


Пожалуй, с этой статьи начну цикл статей про OpenVZ виртуализацию на сервере под управлением Debian.

Выдержка из wiki:
OpenVZ — это реализация технологии виртуализации на уровне операционной системы, которая базируется на ядре Linux. OpenVZ позволяет на одном физическом сервере запускать множество изолированных копий операционной системы, называемых VPS (Virtual Private Servers).

Поскольку OpenVZ базируется на ядре Linux в роли «гостевых» систем могут выступать только дистрибутивы Linux. Однако, виртуализация на уровне операционной системы в OpenVZ даёт лучшую производительность, масштабируемость, плотность размещения, динамическое управление ресурсами, а также лёгкость в администрировании, чем у альтернативных решений. Согласно сайту OpenVZ, накладные расходы на виртуализацию очень малы, и падение производительности составляет всего 1-3 %, по сравнению с обычными Linux-системами.